Jump to content
  • 0

App not working


Shamica
 Share

Question

  • Answers 15
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

15 answers to this question

Recommended Posts

  • 0

@Shamica I promise your issue is still being looked at by our team! Jodi from support documented and escalated it and our app team and they are still testing and working on your particular issue.

 

We are working to increase the reliability of the app, thank you @Nueva Koehler for the tip in the meantime.

 

Appreciate all this feedback, thank you!

Link to comment
Share on other sites

  • 0
13 hours ago, LM LPN said:

Yes I'm having the same issue and it takes like 15 to 20 minutes to load app.

Hi @LM LPN I'm sorry you're having trouble loading the app. We've found that sometimes slow loading can be your connection. If you're on WiFi, you could try a different WiFi network or even switching to data (if that's an option for you). Then vise versa if you're on data -- you can try a WiFi network. If that doesn't do the trick, you can always contact Support to try more troubleshooting steps.

Link to comment
Share on other sites

  • 0
On 9/23/2022 at 11:59 AM, Shamica said:

All of these shifts that say scheduled I wasn’t scheduled for the shift but according to app I was. 

4350E0CE-089A-49F5-AEE2-00C33E748E86.png

1D1986A1-4B13-4AD7-B192-D28904DD2006.png

28768DF9-607C-4AA8-9490-E0FEADD4586F.png

EC2B35E1-FEF0-4D44-ABD3-94E5BC524382.png

3805B572-B101-4A8D-9734-C8AFA9E0F1B6.png

Mine are out of order too, I just made a post about it. @Krishna Floisand made it into a voting to see if other are having similar issues or would like it to be in order. You should head over and vote! 

Screenshot_20220925-221539_Nursa.jpg

Link to comment
Share on other sites

  • 0

Nursa I see the same complaints on your “community” page and same explanations are given from your support team.  They are not minor and it’s been very disappointing for the past 2 months.  Too many glitches since the new changes have been made to the app.  Now I can’t even get the app to work and give the shifts after using the “filter” that only sometimes work.  I’ve sent many screenshots that have been requested, deleted and reinstated the app, bought a new phone (iPhone 13 pro max), even spoke with one of your representatives.  All we’re asking is to fix this because the very thing that is suppose help your company succeed isn’t working to its capacity like it use to and it’s frustrating!  

  • Comfort 1
Link to comment
Share on other sites

  • 0

hi @Adele! As a newer company, we definitely have lots to keep improving especially when it comes to app functionality. We are the same team helping clinicians, so our answers will be really similar! We have a process to dive into problems and documenting the exact problem is very important for our app team. The issues stated here and in other posts have been escalated and/or taken care of. Sometimes issues can only affect one user or a group of users so we want to make sure we are addressing problems correctly. We do have weekly app updates that are starting to roll out and the big ones are usually noted here: community.nursa.com/clinician-help/app-updates/

 

Let's see where the issues you called about were left off. Again, we are sorry that we are falling short of your expectations and want to succeed so you can succeed!

 

 

 

  • Thanks 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...